Information: National Student Clearinghouse public website issues, please use the secure login page directly to log in

Incident Report for National Student Clearinghouse

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 13:05 EST

Investigating

Our public http://www.nationalstudentclearinghouse.org site is having intermittent issues due to our ISP provider having issues. If you are not able to get to our secure site login off the http://www.nationalstudentclearinghouse.org page, you can navigate directly to the following secure login page and log in from there.

https://id.studentclearinghouse.org/
Posted Dec 05, 2025 - 09:19 EST
This incident affected: Postsecondary Schools - Verifications (Access issues - school users, Access issues - student or commercial requestors), Postsecondary Schools - Secure Site (Access issues - school users), Transcript Services - Postsecondary (Colleges and Universities) (School Site Access issues - TS school users), and Verification Services (DegreeVerify, EnrollmentVerify, DiplomaVerify - Website - Background Screeners).