Service Interruption Alert

Incident Report for National Student Clearinghouse

Resolved

The issues with our Verification Services DegreeVerify, EnrollmentVerify, DiplomaVerify, & Insights API & Website functionality, as well as with our school secure site logins and Transcript Services secure site logins and dependent functions, have been resolved.
Posted Dec 03, 2025 - 13:02 EST

Monitoring

We’re beginning to see recovery with our Verification Services DegreeVerify, EnrollmentVerify, DiplomaVerify, & Insights API & Website functionality, as well as with our school secure site logins and Transcript Services secure site logins and dependent functions. We will continue to monitor verification requests and transcript processing to ensure this recovery continues. As long as no new issues occur by 1 pm EST, we will mark this issue as resolved.
Posted Dec 03, 2025 - 12:01 EST

Update

We’re currently experiencing issues with our Verification Services DegreeVerify, EnrollmentVerify, DiplomaVerify, & Insights API & Website customers, as well as School secure site logins and Transcript Services secure site logins and dependent functions, which may affect your ability to complete verification requests and process transcripts. Our team is working to resolve this as quickly as possible. We apologize for the inconvenience.
Posted Dec 03, 2025 - 09:24 EST

Investigating

We’re currently experiencing issues with our Verification Services DegreeVerify, EnrollmentVerify, DiplomaVerify, & Insights API & Website customers, as well as School secure site logins and Transcript Services secure site logins and dependent functions, which may affect your ability to complete verification requests and process transcripts. Our team is working to resolve this as quickly as possible. We apologize for the inconvenience.
Posted Dec 03, 2025 - 09:09 EST
This incident affected: Postsecondary Schools - Verifications (Access issues - school users, Access issues - student or commercial requestors), Postsecondary Schools - Secure Site (Access issues - school users), Transcript Services - Postsecondary (Colleges and Universities) (School Site Access issues - TS school users, ETX Plus - school users, NextGen - school users, Ellucian eTranscripts Orders), and Verification Services (DegreeVerify, EnrollmentVerify, DiplomaVerify - API - Background Screeners, DegreeVerify, EnrollmentVerify, DiplomaVerify - Website - Background Screeners, Insights JSON API - Enterprise Commercial).