Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 23, 2026 - 22:00 EDT
Scheduled
Many National Student Clearinghouse services may experience intermittent interruptions from 10:00 PM ET on Sunday, August 23, until 12:00 AM ET on Monday, August 24, as we update our technology to improve performance and enhance security. We apologize for any inconvenience.
Services That May Experience Intermittent Interruptions During the Maintenance Window: Transcript Services Student Self-Service (including password reset functionality) StudentTracker for Educational Organizations StudentTracker Outreach DegreeVerify (School Users) Enrollment Reporting Financial Value Transparency & Gainful Employment (FVT/GE)
While we do not anticipate a complete outage, users may experience intermittent service disruptions during the maintenance window. Full functionality will be restored upon completion of the maintenance activities.
Posted Aug 18, 2026 - 09:53 EDT
This scheduled maintenance affected: Postsecondary Schools - Verifications (Access issues - school users), Postsecondary Schools - Secure Site (Access issues - school users), and Transcript Services - Postsecondary (Colleges and Universities) (Transcript Ordering Site - requestors, Track Your Order Page - requestors, Transcript Download Center - recipients, School Site Access issues - TS school users, ETX Plus - school users, NextGen - school users, Ellucian eTranscripts Orders).