Service Interruption Alert

Incident Report for National Student Clearinghouse

Resolved

This incident has been resolved.
Posted Feb 17, 2026 - 16:41 EST

Investigating

The National Student Clearinghouse is experiencing technical issues with the service(s) indicated below, which may impact users' ability to access or request information through these services. We are currently investigating this issue and will let you know as soon as it is resolved.

We apologize for this inconvenience and are working to resolve this issue as quickly as possible.

Please note that we are unable to respond to questions sent to this email address.
Posted Feb 17, 2026 - 16:19 EST
This incident affected: Transcript Services - Postsecondary (Colleges and Universities) (Transcript Ordering Site - requestors, Track Your Order Page - requestors, Transcript Download Center - recipients, School Site Access issues - TS school users, ETX Plus - school users, NextGen - school users, Ellucian eTranscripts Orders).